Document Corruption

What You Will Learn

After completing this lesson, you will be able to: 

· Identify a corrupt document

· Correct a corrupt document

· Better understand macro viruses

Additional Written Resources

· Microsoft Knowledge Base articles listed throughout this chapter.

· Q87856 - Troubleshooting Damaged Documents in Word 97 for Windows (Knowledge Base) (by e-mail)
· How can I recover a corrupt document and why did it become corrupt? MVP Dave Rado on the MVP FAQ site.

· The Microsoft Most Valuable Professional (MVP) web site.
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WARNING
	While information in this chapter may be useful in recovering corrupted documents, it’s important to understand that none of these recommendations are guaranteed to restore a corrupt document. Try them at your own risk. Any macro code is provided “as is” without warranty of any kind, either express or implied, including but not limited to the implied warranties of merchantability and/or fitness for a particular purpose.


Overview

Being prompted with a message that the document that you’re trying to open may be corrupt is one of the worst experiences that you can have when working with any software application. Corrupted documents can cause any application to exhibit unusual behavior if you are able to open the document. Such behavior occurs because the application attempts to make decisions about what to do next based on incorrect information in the corrupted document.

This chapter provides information on how to reduce your chances for encountering corruption, advice on how you might be able to recover a corrupted document, and information on macro viruses.

Common Causes of Corruption

One of the primary causes of document corruption is when a document is converted from one format to another and back repeatedly. This process is sometimes called round-tripping.  Round-tripping should be avoided at all cost! If not, your chances of document corruption increase greatly – it is no longer if the document will corrupt, it’s when. For more information on round-tripping and other ways to work with converted documents see the chapter on conversion.

Another common cause of document corruption is storing, accessing, and saving a file from diskette. A diskette is useful for transporting files, but once you are ready to work on the file again, be sure to save the file to your computer’s hard drive.

Another sign that will appear to be indicative of corruption can actually be the result of infection by a macro virus. A macro virus works like a conventional computer virus, but takes advantage of Word’s structure and functionality to replicate and trigger when certain events occur. Many macro viruses are only nuisances and don’t cause any damage, but some can be quite dangerous. This information is repeated and discussed in more detail below.
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WARNING
	Common Cause of irretrievable document corruption not identified by Microsoft

	Use of the Master Document feature: Don’t use it! The consensus in the Microsoft users newsgroups is that this feature will corrupt your documents – usually without warning and often irretrievably. This is true through Word 2000 SR2 (and likely forever). Follow the link in this paragraph for more information and work-arounds.

Charles Kenyon


Identifying a Corrupted Document

Corrupted documents often exhibit behavior that is not part of the program's design (for example, infinite repagination, incorrect document layout and formatting, unreadable characters on the screen, error messages during processing, system hangs or crashes when you load or view the file, or any other unusual behavior that cannot be attributed to the normal operation of the program). These behaviors can be caused by factors other than document corruption. 

To rule out other factors, use the following troubleshooting steps:

· Check for similar behavior in other documents. 

· Check for similar behavior in other programs. 

· Take the file in question to another computer and attempt to duplicate the behavior. 

· Use a different printer driver and attempt to duplicate the behavior. 

· Rename any templates attached to the document and attempt to duplicate the behavior. 

· Change other system components (such as video drivers or fonts) and attempt to duplicate the behavior. For example, if you are using an OEM version of a video driver, switch to a Microsoft Windows video driver using the Windows Setup program. 

· Disable any third-party programs that are running (such as terminate- and-stay-resident programs [TSRs], font managers, screen savers, and system shells), then attempt to duplicate the behavior. 

If the problem occurs only with a single document after performing the steps above, your document has probably been corrupted.

Correcting a Corrupted Document

There are several techniques you can use to try to correct a corrupted document. Which method you use depends on the nature and severity of the corruption and the nature of the behavior exhibited. Although many of the methods that follow succeed regularly, not every corrupted document can be recovered. A backup copy of the document is the best way to recover a corrupted document.

Convert the File to Another Format, then Convert it Back to Native Format

This is the easiest and most complete document recovery method; always try it first. Save the file in RTF file format; this format preserves the formatting in your Microsoft Word for Windows document. After you save the file in RTF format, reopen the document in Word for Windows, and convert it from RTF. If this method succeeds, the file corruption may be removed during conversion. If the corruption persists after you save the file in RTF file format, try saving the file in the following file formats:

· Other word processing formats

· Text Only
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NOTE
	Saving files in Text Only format frequently corrects the document corruption problem; however, all document formatting is lost. This method requires more reformatting; therefore, use it only after other file formats fail to correct the problem.


Copy Everything Except The Last Paragraph Mark To A New Document

Word associates a wide variety of formatting with the last paragraph mark, especially section and style formatting. If you copy everything except the last paragraph mark to a new document, the corruption may be left behind in the original document. In the new document, reapply the section or style formatting.
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NOTE
	You can select everything except the last paragraph mark by pressing CTRL+END, then CTRL+SHIFT+HOME.


Copy The Uncorrupted Portions Of The Document To A New Document

Sometimes you can determine the location of file corruption in your document. In such cases, copy everything except the corrupted portion to a new file, then use the following steps to reconstruct your document:

· After you copy the uncorrupted portions of your document to a new file, save a copy of the corrupted document in Text Only format.

· Open the Text Only file. Copy the text from this file that was in the corrupted section, and paste that text into the file that contains the uncorrupted portion of your document.

· Reformat the sections you pasted, and then save the recovered document.

Copy Text and Paste As Unformatted Text

If you can open the document but the document is exhibiting odd behavior that could be due to corruption, you can select and copy the text, create a new document, and choose Edit > Paste Special > Unformatted Text. This strips all of the formatting and underlying problems within the document and provides a clean copy of the text within the document use styles to quickly reformat the document text.

Save as a Previous version of Word

If the document can be opened, save it as a Word 6.0 document. If that is not successful, save it as a Word 2.0 document. This often allows the file to be recovered without corruption.

Open The Damaged Word Document In Draft Mode

Sometimes (not always, due to the nature of damaged documents) you can open a document successfully in draft mode when it will not open in other views. Once you open the file, you may be able to recover or repair the file.

To switch to draft mode in Word, choose Normal from the View menu, then choose Options from the Tools menu, select the View tab, and select the Draft Font option.

-or-

Run the following macro to turn off screen updating, open your damaged document, switch to draft mode, and then reactivate screen updating:

Sub Main

ScreenUpdating 0

FileOpen .Name = "FILENAME.DOC" ' substitute your filename

ToolsOptionsView .DraftFont = 1

ScreenUpdating

End Sub
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NOTE
	In the preceding macro, substitute the name of your damaged document for the "FILENAME.DOC" argument text.


Using this macro may enable you to open documents that you cannot otherwise open due to damage that affects printer setup, page layout, or screen updates in Word. For example, if a general protection (GP) fault occurs in Word before the document opens, you may be able to avoid the GP fault by opening the document using the preceding macro.

Recover Text From Any File

If a Word document will not open and you need to at least get a copy of the text within the document, you can choose File > Open, and in the Files of type drop-down list, select Recover Text From Any File. Using the Recover Text From Any File converter does have its limitations. Document formatting will be lost, along with anything that is not of a text nature. Graphics, fields, drawing objects, and so on, will not be converted. However, headers, footers, footnotes, endnotes, and field text, will be retained as simple text.
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NOTE
	If the Recover Text From Any File converter is not installed, you will need to re-run Setup to install this converter.
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NOTE
	When you change the Files of type box to Recover Text from any File in the Open dialog box (on the File menu, click Open), Word will 'remember' this setting and will use it the next time you open a document. To avoid this problem, reset the Files of Type box back to Word Document (*.doc) after you have recovered the document.


Attempt To Recover A Document That Will No Longer Open, By Linking A Good File With A Blank Document And Then Changing The Link Source To The Damaged Document.

Use the following steps to link and change the link to the damaged file:

1. Create a new document. Type This is a Test. Save the document.

2. From the Edit menu, choose Select All.

3. From the Edit menu, choose Copy.

4. From the File menu, choose New.

5. From the Edit menu, choose Paste Special.

6. Select either Unformatted or Formatted text, and click Paste Link.

7. From the Edit menu, choose Links.

8. The Links dialog box appears. Select the filename of the first linked document and click Change Source (in Word 2.x, the button is Change Link).

9. The Open dialog box appears and asks which document you want to change the link to. Select the document you can no longer open and click Open.

10. Click OK in the Links dialog box (in Word 2.x, enter the path and filename).

11. The data/text from the damaged Document will appear (provided there was any recoverable data/text). On the Edit menu, click Links, and select Break Links (Cancel Links in Word 2.x).

12. You can now reformat and save the recovered text. This method works because during a link, part of the header information is not read. This allows you to open the file if this part of the header is the damaged area of the document.

Macro Viruses in Word

A macro virus may use Word’s macro programming language (VBA) to spread itself through your computer and even the firm network. Macro viruses can cause damage to the document that has the virus, or to other computer software on your machine. Macro viruses can infect Word documents, Word templates, and any other program that uses a programming language.

Unlike previous viruses, macro viruses do not infect programs; they infect documents and templates. When you open a document or template that has a macro virus, it will infect your system. The virus will spread to other documents and templates you may have on your system. Some macro viruses are not harmful, but can be annoying and frustrating for users. Be aware that there are some macro viruses that can be very destructive.

Available Knowledge Base Articles regarding Viruses

Q134727
What to Do If You Have a Macro Virus
Q211800
WD2000: What to Do If You Have a Macro Virus
Q163932
Frequently Asked Questions About Word Macro Viruses
Q161515
Macro Virus Warning Displayed When No Macros Exist in File
Q164339
Macro Virus Warning Message When You Start Word
Q224506
WD2000: "Melissa" Word Macro Virus Alert
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WARNING
	Your firm should invest in a good virus protection software program.


How to Reduce the Chances of Macro Virus Infection

1. Install and update anti-virus software that is specifically designed to detect macro viruses. For a list of anti-virus software vendors see: http://support.microsoft.com/support/kb/articles/Q49/5/00.ASP . 

2. Set a security level in Microsoft Word – Word 2000 Only. From the Tools menu, choose Macro and then Security. On the Security Level tab, select the security level you want and then click OK.

3. Protect the global template (Normal.dot). To prevent some macro viruses, you can apply password protection to the Normal.dot. To do this, alternate-click on the Normal.dot file and choose Properties and select the Protection tab. Apply a password, confirm the password and click the OK button. You can also set password protection by choosing Tools, Macro, Visual Basic Editor. Alternate-click on the Normal project and select Normal Properties. Apply password protection and click OK.

Many, but not all of the viruses add macros to the Normal template. By protecting it – you eliminate this risk.

For more on recovering from corrupt documents see:  http://www.mvps.org/word/FAQs/AppErrors/CorruptDoc.htm
See Modifications for information on revisions made to this guide by Charles Kenyon.
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