 
	Templates in Microsoft Word 
by Charles Kyle Kenyon, Esq.
You will find an earlier version of this chapter on the Microsoft site. Users of Word 2007-2021/365 (Ribbon versions) may want to look at this note.
Last updated .
Comments are welcome. A Word document version of this chapter (seldom updated) is available here.
Introduction. Templates are a special type of Word file that can hold text, styles, macros, keyboard shortcuts, custom toolbars, QAT and Ribbon modifications,  and Building Blocks including AutoText entries for use in other documents.
This is different from the standard English-language term "template" although derived from that term. It is jargon.
 
A document created using a template will have access to all of these features and a large part of your job in creating a new document will be done for you if your templates are well thought out. You don't need to use all (or even any) of these features for templates to help you and those with whom you work. There are document templates, that share these resources with documents based on the template, and global templates that share resources with all documents.
This is an intermediate to advanced-level tutorial and it is recommended that you not try anything in here until after you have reviewed the contents of at least the chapters
	
	Basic Formatting

	
	Understanding Styles

	
	Sections - Headers and Footers

	
	Numbering

	
	Complex Documents

	
	Automated Boilerplate Using Microsoft Word - Autotext Autocorrect Building Blocks and more


You don't have to understand everything in those chapters to build a useful template, but it will help for you to at least have skimmed through so that you will know some of the pitfalls and advantages of different methods. I also recommend going through all of Shauna Kelly's Basic Concepts of Microsoft Word.
What You Will Learn
After completing this lesson, you will be able to: 
	
	Distinguish between a "template" and an ordinary document.

	
	Distinguish between a document template and a global template.

	
	Save a document as a template.

	
	Attach a different template to your document.
	
	Understand what you get from the template when you attach a different template.

	
	Understand what can happen if there are multiple templates with the same name in different locations on the computer.




	
	Open a template for editing.

	
	Find the location of templates your Word installation uses: 
	
	User Templates and the Normal template

	
	Workgroup Templates

	
	Startup (Add-In) Templates

	
	[Quick] Style Sets




	
	Make additional tabs under File => New or remove unwanted tabs.

	
	Get the classic new templates dialog in Word 2007 or 2010

	
	Set up and use Workgroup Templates.

	
	Create a global template (your own Add-In).

	
	Share a global template on a network.

	
	Learn more about Word's special Normal template.

	
	Copy macros, styles, and autotext entries from one template (or document) to another.

	
	Know what stays in a document from its template when the attachment is lost.

	
	Copy keyboard shortcuts from one template to another.

	
	Understand that there is a definite hierarchy among the templates for customizations defined in more than one template.

	
	Use VBA (macros) to automate your work.



Additional Written and Web Resources
	
	Templates Listing - Web Resources

	
	Microsoft Word Templates by John C. Hill - a class handout at University of Virgina - a basic starting place - introduction to templates

	
	Create a Template Part 1 - Suzanne S. Barnhill, MVP

	
	Create a Template Part 2 - John McGhie, MVP (must reading)

	
	Word for Law Firms by Payne Consulting Group 
	
	Word 97 for Law Firms (also at Amazon.com UK)

	
	Word 2000 for Law Firms (also at Amazon.com UK)

	
	Word X (2002) for Law Firms (also at Amazon.com UK) 




	
	This chapter in Word format.

	
	How to Install a Template on a Mac by John McGhie, MVP

	
	Word:mac - The Normal Template  by John McGhie, MVP, Beth Rosengard, MVP, and Daiya Mitchell, MVP.

	
	What Do Templates and Add-Ins Store by Dave Rado, MVP

	
	How to Find or Open the Normal Template in Microsoft Word, by Charles Kenyon

	
	So You Want to Write a Book Using Microsoft Word - extensive tutorial by MVP Daiya Mitchell with overview of Styles, Templates and Sections and the interactions among these tool/features. Excellent! Not just for those who want to write books!



	
	Word Documents and Templates by Bill Coan, MVP

	
	User/Workgroup Templates Template Locations by Graham Mayor, MVP

	
	Moving (Sharing) Customizations in Microsoft Word by Charles Kenyon

	
	Organizing Your Macros by Beth Melton, MVP - includes organizing your global templates

	
	What is the relationship between a Microsoft Word document and its template? by Shauna Kelly, MVP

	
	What happens when I attach a new template to my document? or How do I copy content and settings from a template to a document? by Shauna Kelly

	
	Where Is (What Is) My Word Startup Folder?

	
	Do You Want to Save Changes to the Template? - But you didn't make any changes!

	
	Installing Templates with macros - video by Laura Townsend

	
	Why is My Blank Document Not Blank? by Suzanne Barnhill, MVP

	
	How to Find or Open the Normal Template in Microsoft Word

	
	Deploy Custom Templates in Office 2010 - MSDN

	
	Using Global Templates to add functionality to MacWord by John McGimpsey

	
	How Templates, Styles, and Building Blocks Relate to One Another in Microsoft Word by legal guru Deborah Savadra (video)

	
	Normal.dot Template Explained (archival) by Dian Chapman, MVP, MOS

	
	Creating a Hyperlink to a Template that Starts a New Document

	
	Create an Easily Customizable Template in Word 2010 - Microsoft Tutorial Video

	
	Getting Started Using Templates in Word 2010 - Microsoft Tutorial Video

	
	How to Create a Template for a Legal Brief - Webinar by legal guru Deborah Savadra

	
	Word 2007 & Later Key Data File Location by Paul Edstein and Charles Kenyon

	
	Use local templates with Office 2013 and later by Diane Poremsky, MVP 

	
	Microsoft Word 2010 Bible by Herb Tyson, MVP


  
	
	[bookmark: SampleForms]Sample Forms (all templates) - All in zip format. 
	
	Public Defender Payment Voucher - Summary cover sheet with five time sheets. Extensive use of tables, cross-references, calculated fields.

	
	Public Defender Transcript Request Form (based on printed form - wild layout of fields using tables, some use of bookmarks, use of exit macros to control tab order.

	
	Public Defender Investigator / Expert Request Form (based on online form prepared by Wisconsin Public Defenders' Office).

	
	ASK fields sample form  (Template)

	
	UserForm sample  (Template)


 


  

(this guide table of contents) ------- (MS Word New Users FAQ) 
[bookmark: 2010]Note about the Ribbon Versions of Word (2007 - 2021)
Almost all of this chapter applies to these later versions of Word. The filename extensions are different in that they will be ".dotx" and ".dotm." File locations for templates with later versions of Windows and Word are more confused, usually in a user profile. A template remains a special kind of Word document that will create a new document when you double-click on it from Windows rather than opening. These later versions of Word do not have toolbars except through Add-Ins or the QAT. See Ribbon in Word 2007 - 2021 for more information on the Ribbon interface.
Templates - User Templates, Workgroup Templates & Global Templates
"Template" is a term of Word jargon. In general, in English "template" means a form or stencil. Forms in Word are a separate matter; they can be contained in Word templates, but are not the "templates" we are talking about. Generally, in Word when someone talks about a template, the subject is a document template.
The templates covered in this chapter are a special type of Word document. They can hold components for other documents, especially text and style definitions. Finally, they can hold additional modifications to your user interface such as  Autotext and other Building Blocks, Keyboard Shortcuts, Macros & Toolbars/Ribbon/QAT Modifications.
"I guess we should recognise that according to Microsoft's research, “normal” users do not use or even know about templates. When Word comes out of the box, it is set up to cater for users who do not understand word processing."
John McGhie, How to Create a Template, Part 2
When you save a document as a template Word will attach the extension of ".dot" to the end of the name instead of ".doc" but it is not the extension that makes it a template. Merely changing the name either way will not change a document into a template or a template into a document (although doing so will confuse you and other users). Although Windows will think that such a misnamed file is a document, or template, depending on the extension, Word knows the difference. You can make a document into a template from within Word using Save As under the File menu. With Word versions prior to Word 2002, you can't directly change a template into a document. You can create a new document based upon a template and save that document . . . as a document. (In Word 2002+ when you use "Save As" to save a template as a document, Word will strip out all AutoText/Building Blocks and will warn you that this will happen before completing the save.) 
In Word 2007 and later the filename extensions are different: docx/docm for documents and dotx/dotm for templates.
Although this chapter is titled "Template Basics" it does not tell you how to create a useful document template. For me to attempt to do that would be pointless. Anything that I would say to you can be found in How to Create a Template Part 2 by John McGhie. I urge you to read that work, now. This chapter, though, does tell you things about templates that are not covered in that work.
If you are creating a document template, I urge you to pay close attention to styles. In constructing or editing a template:
"Always change formatting with Format>Style " .  I may sometimes forget to say so, in which case please remember it for me!  ...[R]emember: for most users, the only thing they can ever access in a template is the styles.  If the settings are not in the styles, they’re pointless." 
John McGhie, How to Create a Template, Part 2
I would go further and say template formatting done directly (outside of styles) is wicked or cruel. It will confuse the user of your template and make life more difficult for him or her. If you are the user of your template, I guess foolish and self-defeating would be a better description than wicked or cruel. None of these adjectives are ones that I use often or lightly. I think they are appropriate in this situation. Word 2010 makes use of styles even easier and more important. See Why Use Styles - part of Lynda.com Video tutorials on Word and Understanding Styles in Microsoft Word.
	
	[bookmark: hiding]NOTE about hiding things from yourself. 
Both Word and Windows like to hide things from you feeling that too much information tends to confuse. You may agree with this philosophy or not. However, this chapter is written expecting that you can see some of this hidden information. Specifically:
	
	Filename Extensions (Mac users don't need to worry about this.)


If you are in an Explorer window that has Word documents in it, do the names show the three-letter extension ".doc?" If not, to see these you need to go to the menu: View => Folder Options => Views (tab). (Later versions: .docx/.docm.)
Uncheck the selection that says something like "Hide filename extensions for known file types" and click on OK or CLOSE.
For more see this knowledgebase article.
	
	Paragraph marks and section marks


These non-printing characters are at the heart of word formatting. If you can't see them, your formatting will be very hard to figure out. This is one part of the Word equivalent to Word Perfect's "reveal codes." The default is to not show these characters because the marketing people at Microsoft thought it would scare you to have any clue as to what was going on in your document. (my guess) When you are working on formatting a document you need to see them. The Show/Hide toolbar button (Standard Toolbar, between Document Map button and Zoom drop-down) for this has a paragraph mark (pillcrow) on it. You can also set this under Tools => Options => View (tab). See Show Non-Printing Marks in Microsoft Word.
	
	You can change these back later. Most advanced computer users leave these displayed to save time because not seeing these confuses them.


 


[bookmark: attached]Creating a document from a document template - the attached template.
In Word 97-2000, when you select New under the File menu, you are shown templates from which you can choose. There are also Tabs of more available selections. (And if there isn't room for all of the tabs, there will be one that simply says "More" and gives you access to the others.) When you pick a template and create a new document based on that template, the template remains "attached" to the document. 
(In Word 2002-2003 you need to choose "On my computer" to see this dialog. In Word 2007 it is under the Office Button. New > My Templates... In Word 2010 - 2021 it is under the File Tab. New > My Templates. See File New Variations in the Versions of Microsoft Word for more on this.)
Any text that is in the template will be the start of your new document.
All styles in the template used in the document (whether in the template's text or in text that you type or insert) become defined in the document and will stay with the document even if the attachment is later broken. If the template's style definition is changed after it is used in the document, the style as used in an existing document will not change unless the template is reattached or the style is otherwise copied into the document again. (See below for more on attaching a template to an existing document.)
Autotext/Building Blocks entries, Macros, Keyboard customizations and Toolbars/QAT Modifications in the template are available to the document so long as the document remains attached to the template, but are not normally transferred into the document. (Documents cannot hold Autotext/Building Blocks entries but can hold macros, keyboard shortcuts, and toolbars/QAT Modifications.) If you use XML to modify the Ribbon in later versions of Word, those modifications can be stored in either documents or templates. 
In Ribbon versions (Word 2007 and later) you can map content controls in a to an XML Node in the template. Those mappings will continue or be useful in documents based on the template. Attaching the template at a later time, though, will not transfer the mappings.
For more about mapped controls, start with the Document Property Content Controls built into Word. Repeating Data Using Document Property Content Controls and Other Mapped Content Controls 
See What is the relationship between a Microsoft Word document and its template? by Shauna Kelly, MVP, for an idea of which elements of the template are part of the resulting document.
You can create a document template based on a document by saving it as a template.
 
	
	Rant about creating Templates from (flawed) documents 
If you are going to share your templates with others, or simply plan on using them to make a number of documents try to plan and structure them with care. Avoid making a template from any documents converted from a different word processing program or even a much earlier version of Word. Because there is no way to translate feature-for-feature a complex document structure from one program to another, these conversions are prone to document corruption. In Word, even documents created in the current version of Word can cause problems if they have automatically numbered paragraphs.
The basic idea of templates is to give you or someone else a boost in creating a new document. If your template is full of errors, those errors will replicate themselves ad infinitum! That isn't something that you need. It isn't an example that you want to set.
If what you really want to share is text, try sharing it as an AutoText entry.
To clean up text from a converted document, save it in RTF (or even text) format, reopen that and save it again as a document file. Copy that text into a new document based on a solid template. Save that new document as your template. Then apply appropriate styles to all of the text in your document. See below for more on use of styles in templates.



 
 Template
If you move the document to a different computer that doesn't have the template, the attachment will be broken. If you move the template into a different directory on your computer, the attachment will probably be broken. If your template is on your server and you give the server a different name, the attachment will be broken. You can change the template attached to a document using 
Tools => Templates and Add-Ins...
[bookmark: gives_you_access]Attaching a different template gives you access to any AutoText, macros, toolbars (QAT modifications) and keyboard customizations in the newly-attached template. It does not give you any text from the newly-attached template. It gives you access to styles in the newly-attached template but unless you check the box "update styles" when you change the attached template, any styles already in use in your document will not be changed by attaching a new template. You will also not get any document layout such as margins (although indents contained in styles will be imported if the style is imported. Once you have imported styles, it is important to uncheck the box to import them. What happens when I send my document to someone else? Will Word mess up my formatting? 
If you want the layout features or text from the new template for your document, your best bet is to create a new document based on the new template and then copy the contents of your old document into the new document. Then close the old document and save your new document using the same name. Note that your new document will use style definitions from the template rather than from your old document.
In Word 2007-2021(365) you can reach the dialog for this on Developer Tab. Then click on the Word Add-Ins or Document Template button.
[bookmark: Which_template_is_attached]Which template is attached to a document if there are different templates with the same name in different locations? Word 2003-2021
If you create a document from a template, that is the attached template for that document, unless there is a different template with the same name on the computer in one of three places:
1. The same folder as the document. If there is a template with the same name as the attached template in the folder containing the document, Word 2003-2021 will attach to that template the next time the document is opened.
2. The User Templates folder. (Word will not attach a template of the same name if there is also one in the same folder as the document.)
3. The Workgroup Templates folder. (Word will not attach a template of the same name if there is also one in the User Templates folder or the folder containing the document.)
That is, it completely ignores the existing attached template and attaches to a closer template. This cannot be reset using the Document Template or Templates and Add-Ins dialog. 
Note that when you have a template of the same name in the same folder as the document, Word will not attach to a template with the same name in a different folder.
Templates that are in subfolders of the User Templates Folder or the Workgroup Templates folder do not have this feature of mandatory attachment. For that matter, neither do templates in a subfolder of the folder containing the document.
I have not tested this in Word 97-2002. In Word 2013-2021, note that the Custom Office Templates folder or folder designated as the default save location for templates is not in this hierarchy!
[bookmark: UserTemplates]User Templates Folder
A user's document templates are usually stored in a folder (usually on the user's computer) and normally called "Templates." The normal.dotm (or normal.dot) file will always be located in this folder. The default location of this folder differs among the various versions of Word. Both the location and the name can be changed by the user. If you ask Word to save a document as a template, in Word 97-2003 this is the folder you will be taken to for that purpose. You can see (and change) the location by using:
Tools => Options => File Locations (tab)
In this window, the folder is designated as the "User Templates Folder." Otherwise, see How to Find the User Templates Folder.
[bookmark: default_location07]In Word 2007 and 2010 the default location of the User Templates folder is 
"C:\Users\[your username]\Appdata\Roaming\Microsoft\Templates"
This is still probably the best place to store any template unless you have a reason to put it somewhere else. When a template is in the user templates folder, it will be available under File -> New to create a new document based on the template. In the File Save and File Open dialogs this will show up as "Templates" in the Favorites on the right.
[bookmark: Word_2013UserTemplatesFolder]In Word 2013-2021 (365) the default location of the for new templates is a subfolder of the user's documents folder named "Custom Office Templates." This folder location can be changed under File -> Options -> Save. If you are going to be using the Classic FileNew dialog, you probably want to change it to be the same location as your user templates folder.
The default location of the User Templates Folder remains C:\Users\ user name \AppData\Roaming\Microsoft\Templates.
The User Templates folder will still contain the Normal.dotm template. The location of that folder can be modified (or discovered) using File -> Options -> Advanced -> File Locations.
See this discussion on the Word Answers site for more about the distinction between these two locations in Word 2013 for templates.
It is my recommendation that users make both of these locations (User Templates and Default Custom Templates) the same folder to avoid confusion.
 
 

You can save templates any place you want to, but if you want them to show up in the File => New dialog box they must be in either the User Templates Folder or the Workgroup Templates Folder.
In Word 2013 and later, if you want them to show up on the File > New > Custom dialog, they must be stored in either the Workgroup Templates folder or in the folder designated for storage of new templates. See File New Variations in the Versions of Microsoft Word.
Here are some samples of files that could go in a user templates folder or one of its sub-folders:
	
	Business Cards

	
	Basic Letterhead with continuation header

	
	CD / DVD Jewel Case Insert


These templates could, instead, go in the ...
[bookmark: Workgroup]Workgroup Templates Folder
Every Word installation will have a User Templates folder upon installing the software. That is always the location of the normal template.
The Workgroup Templates Folder is a second top-level folder used to store document templates. (As with the "User Templates Folder",  "Workgroup Templates Folder" is a description, not a necessarily a name.) Unlike the User Templates Folder, there is no default name or location for the Workgroup Templates Folder. In addition, there is no folder upon installation, you need to create one. I call mine "Shared Templates" and it is kept on the server in a folder that is mapped as the "G:\" drive by the network. (And at home I use the assign command to map a folder in the same way so that I can transfer work back and forth.) 
This is set up the same way as the Templates folder except that the folder is in a location accessible to all users (perhaps as read-only). Like the Templates folder, folders established in the Workgroup Templates folder will show up as Tabs when you use the File => New command (Word 2000 requires at least one template in the folder for it to show up). Once you have created a Workgroup Templates folder, you need to modify the settings for each user in Word.
See Workgroup Templates for how to set or modify this in the different versions of Word.
This should be a different folder than the User Templates folder even if on the same computer. For an example of templates designed for placement in Workgroup Folders look at any of the Sample Forms listed under additional materials. If it is on the same computer as the User Templates folder, it should be in the folder that holds the Templates folder, not in the Templates folder. This folder is normally named "Microsoft Office." It's location will vary by version of Word as well as Operating System. See the bottom of How to Open the Normal Template for the variations. The User Templates and Workgroup Templates folders (and their subfolders) are the usual location for document templates. Note that these locations are set initially by the Office Setup program (possibly using network administration policies). 
If there are form documents used throughout an office, department, household, or business, they are best stored as Workgroup Templates. Generally the workgroup templates are prepackaged templates for use by more than one user, often company-wide. They can be used by an individual to distinguish work templates from personal templates or finished templates from development templates.
You can change the location of your user and/or workgroup templates folders but doing so changes it for all Office programs, not just Word. 
Distributing Workgroup Templates
My recommendation for workgroup templates in a networked environment is to keep them on a server and to have the user login copy/refresh them locally. That is, for individual users, they are stored on a local drive. See the discussion of sharing global templates below.
 
Custom Office Templates Folder (Word 2013-2021/365 and later)
Office 2013-2021/365 comes with one other standard template location. By default, this a separate folder is in the users Document Folder. That is set in the Save Options and is the place where newly created templates will be saved by default. (In earlier versions, new templates were saved in the User Templates folder by default; this stopped with Word 2007.)
This is the folder that shows up on the Document > New screen (and Start screen) in Word 2013-2029 as Personal or as a Folder under Custom. See File New Variations in the Versions of Microsoft Word and Word 2013 Startup Screen.
There is one kind of template, though, that should not be in any of these special templates folders, the global template...
[bookmark: Global]Global templates - very different from document templates
Global templates are one type of "Add-In" for Word. Global templates are different from document templates, so different in function that giving both the name template causes endless confusion. They are normally not "attached" to any document and normally do not contribute text or styles to any document. They are excellent vehicles for holding and sharing Autotext, Macros, Keyboard Shortcuts, and Toolbars. In Ribbon versions of Word, they also can hold Building Blocks and QAT and Ribbon modifications. You can make any template global with:
Tools => Templates and Add-Ins ... => Add (button)
In Ribbon versions of Word you click the Document Template button on the Developer Tab
A file open dialog box will open showing the User Templates folder's contents to choose from. You can, though, add a template that is located elsewhere. Since they don't contribute text and are not used to start new documents, global templates are probably best kept elsewhere (and not in the Workgroup Templates folder either). If you add a template as an Add-In this way, it will remain global until you restart Word. At that time, you could add it again, if you wanted to do so. Or, you could make it load automatically on startup by putting the template or a shortcut to the template in the Word Startup Folder. This is not the Startup programs folder in your Start menu, but rather one specifically for Word. You can find (or change) its name and location. See Where Is (What Is) My Word Startup Folder?
Note, Word uses templates (.dot, .dotx and .dotm files) not documents (.doc, .docx or .docm files) as Add-Ins when placed in the Startup Folder. Word will not use ordinary documents, with or without macros, as automatically loaded Add-Ins.
Note that since Word 2000, Word has recognized two startup folders to hold global templates. The first is the folder designated as the Word startup folder under
Tools => Options => File Locations (tab)
In Ribbon versions of Word you find Word Options (Under the Pizza button in Word 2007, File in Word 2010-2021) (Word) Options => Advanced => File Locations (button)
The second is the Office Startup folder. Its location will vary depending on both the Operating System and the version of Word (Office) being used. I believe that the Word Startup folder can be different for each user in later versions of Windows but that the Office startup folder will always be in the Programs folder rather than in the user profile.
Beginning with Word 2007, Add-Ins that only share AutoText (no macros or QAT modifications) can also be placed in the Building Blocks folder. See here for information on the location of that folder.
Examples of global templates can be found in the Legal Toolbars, the Letterhead System and the Gender Toolbars. Information on moving / copying customizations to a global template can be found in Moving (Sharing) Customizations in Microsoft Word.
Templates are one type of global Add-In, another is the .com file (since Word 2000). Those not Word files and are beyond the scope of this article. In the versions of Word that use both, you can find out which ones are installed and enable/disable them.
A Global template can share styles using macros. 
Here is one that will copy all of the styles from a global template other than the Normal template. See A Global StyleSheet? for more on this and a safer implementation.
Sub CopyAllStylesGlobal ()
  ' Copies all styles from Global Template
  ' 2020-01-12  Charles Kenyon
   ActiveDocument.CopyStylesFromTemplate.ThisDocument.FullName
End Sub
See Installing Macros by Graham Mayor for instructions on what to do with a macro listing if you don't know.
 
You can download some free Add-In templates from:
Word Downloads Page - samples of files that work as Add-Ins
	
	Create New Documents Using Custom Template Instead of the Normal template

	
	Letterhead System - Update all letter forms at once

	
	Gender Toolbar - AutoText for Gender-Specific terms

	
	Checkboxes without Form Fields - especially for Word 97-2003

	
	Legal Toolbars

	
	Filename and Path Add-In

	
	DateLoader Add-In - changes Alt+Shift+D keyboard shortcut from DATE field to CREATEDATE field

	
	2003 WordArt for Word 2010-2021

	
	Animated Text Effects in Ribbon Versions of Word


See also Using Global Templates to add functionality to MacWord by John McGimpsey.
[bookmark: sharing] Sharing a Global Template on a Network
If a global template is to be shared over a network, it should be placed in a folder on the network server to which all users have file read access. Each user's network login file should be set to copy the file to the user's personal startup folder when the user logs onto the network if the network version is newer than the user's version. That way you can update the template without everyone having to be off from Word when you do it. (The personal startup folder can be on a network drive or a local drive; my preference is to use a local drive so that users have access to it even when offline.)
If you can't work with the login scripts or aren't worried about updating the template  you will probably want to use shortcuts (Mac: aliases) to it in each user's Word Startup folder. That way, any changes will automatically update everyone's Word. If it is your own and not shared you can either put it in your Startup folder or keep it elsewhere and use the shortcut to load it into Word.
 
Building Blocks Add-Ins
Word 2007 introduced a new kind of Add-In, one to hold only Building Blocks including AutoText. .Dotx templates can be stored in either of the Startup folders mentioned. They can also be stored in a Building Blocks folder. 
If stored in a Building Blocks folder, the template will only share Building Blocks/AutoText.
A .dot template can store only AutoText, not other kinds of Building Blocks. 
It can be loaded as an Add-In but I do not know that it will function if placed in a Building Blocks folder.
Temporary Global Templates
You can use a global template which is not loaded at startup, as well. Such a template can share resources which are not used or needed in most of your documents but are used by multiple templates and their documents. To do this, you would include a VBA command in the AutoOpen and AutoNew macros of the templates that need those resources. These would load your global as an Add-In for that session of Word only. This way, when one of the documents needing your template's resources is created or opened, the resources will be available. Word will also (in some versions, at least) load a document as well as a template as an Add-In using this method. Documents, however, will not be loaded automatically even if placed in the Startup Folder.
A good place to store such a global template might be in a folder in your Word Startup folder named "Temp." 
That way it would not load at startup, would be easy to find, but would not show up in your File => New... dialog box.
See also: Organizing Your Macros by Beth Melton, MVP and Organizing Your Macros/Template Add-Ins by Greg Maxey, MVP - includes organizing your global templates. 
Note: Building Blocks templates stored in the Building Blocks folder will not show up in any list of Add-Ins created by Word, unlike those stored in one of the Startup Folders.
	
	Sample Global Templates 
	
	Letterhead System Templates This is a work in progress that I put together in response to a question on one of the Microsoft newsgroups. It is a complete system for self-updating letter forms. The idea is to have letterhead components stored in one location and have letter forms reference that location when used so that form letters will have the latest letterhead information.

	
	Legal Toolbars (Global Template)

	
	Gender toolbar Add-In (Global template)

	
	Checkbox Template - add clickable checkboxes to non-Form documents

	
	Random Text Add-In - add random text to a document or template (Quick Brown Fox, Microsoft Help Text, or Lorem Ipsum)

	
	Continuous Page Numbering Add-In Fixes page numbering problems in complex documents

	
	Bar Code Add-In - Simplifies insertion of QR Barcode in Word 2013 or later

	
	Other Add-Ins 





[Quick] Style Sets - .dotx templates not used as templates!
Style Sets are stored in .dotx templates and only share styles designated to display in the Quick Styles Gallery. 
They are not used as the basis for new documents. When selected, they overwrite those styles in the current document.
See [Quick] Style Sets in the Styles chapter.
[bookmark: Normal]Normal.dotm - the pan-global template - the granddaddy of all document templates
Normal.dotm (Normal.dot in Word versions previous to Word 2007) is a special global document template created and used by Word. It is a global template, and it is often used as a document template. Unlike other global templates, Normal.dotm / normal.dot must be in the User Templates folder. Unlike other global templates, it should not be shared. See You Cannot Share the Normal.dot[m] File Among Multiple Users - from Microsoft. Also unlike other global templates, it shares styles with all open documents (including other templates). 
When you click on the new document button or go to File => New and select "Blank Document" what you get is a document based on the Normal.dotm template. (It is possible to change this and have the default new document be based on something else. See Easy New Document Template Package for ideas on how this can be done.)
The Normal template is the repository for many user customizations. Generally when you have the option of saving a customization like a change to a built-in Style, a new Style, a macro, or a keyboard shortcut to "all documents" or "all documents based on this template," the place you are saving to is the Normal template. Alterations to the Quick Access Toolbar or Ribbon in later versions of Word made from within Word are saved in separate files. See Modifying the Ribbon UI. Unformatted changes to AutoCorrect are also saved in separate files. See Automated Boilerplate in Microsoft Word. For more on where customizations are stored see Word 2007 & Later Key Data File Locations.
The Normal template is usually considered at least as personal as the locked bottom drawer of someone's desk. People will be offended if you mess with their Normal.dot(m).
If Word is unable to find the Normal.dotm file when started, it will create one, using its defaults, as soon as you change a default. If you do not change any defaults in a clean installation of Word, there will be no normal template.
The installation default for the location of Normal.dotm is the user templates folder. (In some language editions, Normal.dotm will have a slightly different name. Also, at least one virus renames Normal.dot(m).) Except in unusual circumstances (multiple users on one computer or multiple versions of Word) there should only be one copy of Normal.dotm / Normal.dot (named Normal.dot) on a computer. Note that when an earlier version is upgraded to Word 2007 or above there may be both a Normal.dot and a Normal.dotm in the user templates folder. This is quite acceptable, but Word 2007 and later do not use the normal.dot file as the basis for new documents. Word does not automatically create a file named Normal.dotx, any such file was created by the user or by other software.
One of the most used methods of diagnosing or curing problems in Word is to rename the normal template. See How to Find or Open the Normal Template in Microsoft Word, by Charles Kenyon
	In one of the Word forums I was challenged over my statement that "Only Word can create a normal template." It may be, in the ribbon versions of Word, that it is possible to create a functional normal.dotm template from a saved document. I do not know. I do not think it is wise even if you can.
Word creates a normal template from the program itself when none is present. It saves this when the program is closed if anything has been done to change the defaults stored in the normal template. When created, in all versions of Word the normal template will contain:

	Page Layout including:
	
	Margins

	
	Styles

	
	Fonts and Colors of text

	
	Page orientation



	This is true of any template. It is just that new documents are based on the normal template by default.
It is good practice to have separate templates for different layouts.

	Formatted AutoCorrect
	There are some formatted AutoCorrect entries stored in every new normal template. The exact entries depend on the version of Word. If someone wanted these in a template based on a document and saved as the normal template, they could be recreated in that template.

	AutoText
	AutoText is stored in the normal template, by default. It can be stored in any template. I believe that the default storage location in Word 2007 is the file Building Blocks.dotx. The screenshot below shows some of the AutoText build into Word 1997-2003's normal.dot file:

The Header/Footer entries are also available in the Header/Footer toolbar. There does not appear to be any AutoText distributed with Ribbon versions of Word. The built-in entries have been transferred to other building blocks.
See Automated Boilerplate Using Microsoft Word - Autotext Autocorrect Building Blocks and Sections / Headers and Footers in Microsoft Word
In Word 2010 AutoText stored in the Normal template can use the AutoComplete function that was available in earlier (menu-based) versions of Word. In Word 2013 and later, the AutoComplete function works with AutoText stored in any location.

	Building Blocks
	Any kind of Building Block can be stored in a template (and only in a template). The default template for storage of Building Blocks other than AutoText is the file Building Blocks.dotx. Other templates may be better suited for this. The Normal template is generally not a good storage location. See Where Can Building Blocks be Stored for more.

	Keyboard Shortcuts
	As with other templates, keyboard shortcuts can be stored in the normal template. As with other global templates, shortcuts stored in the normal template are available in all documents and templates, whether created based on the template or not.
The default keyboard shortcuts are not stored in the normal template. They are in the program itself. It is modifications to those shortcuts that are stored in templates including the normal template. This is true at least back to Word 97.

	Macros
	As with other templates, macros can be stored in the normal template. As with other global templates, macros stored in the normal template are available in all documents and templates, whether created based on the template or not. The default storage location for recorded macros is the Normal template's "New Macros" module.

	Toolbars and Menus(Word 97-2003)
 
(Ribbon Versions)
QAT and Ribbon
	As with other templates, custom toolbars and menus can be stored in the normal template. As with other global templates, these customizations are available to all documents and templates, whether or not based on the normal template.
In Ribbon versions, a representation of toolbar and menu modifications show up under the Add-Ins Tab. In Ribbon versions QAT modifications can be stored in the normal template. They probably should be stored there when they are using macros stored there. Likewise, Ribbon modifications can be stored there, with extra and unnecessary effort. The normal template is not the best place to create or store QAT and Ribbon modifications. See Modifying the Ribbon and QAT.

	As an experiment, in Word 2010 I had Word create a fresh normal.dotm and compared that file with a normal.dotm that I had created by saving a document as a macro-enabled template that I then named normal.dotm and placed it in the user templates folder. The normal.dotm created by Word was 23K in size; that from the document was 13K in size. When the XML structure was examined, the one created by Word had extra components, especially a glossary folder. That folder contains information about, among other things, the display of styles and the Quick Style Sets.
In conclusion, as far as I know, in the ribbon versions of Word, if you attempt to create your own normal template, you lose the Formatted AutoCorrect entries that come with a normal.dotm file created by Word. You do lose more, but I am unsure of what that more is. There is no reason I know of to try to create your own normal template. Instead, I advise modifying the template created by Word.


Numbering Templates
Note that there is yet a fourth kind of template - not covered in this chapter - is the numbering list template. 
For some unfathomable reason Microsoft chose to use the term "template" for its numbering lists as well. These are registry entries and not separate files, unlike the templates addressed in this chapter. See the Numbering chapter for more on these and Word's Numbering Explained for much more. 
[bookmark: hierarchy]The hierarchy of templates - what happens when there are resources with the same name in different active templates?
We have the open document, the attached (document) template, any loaded global templates, and Normal.dotm/Normal.dot. 
All of these can store various customizations that can act in the document. They may conflict. 
What happens if there are conflicts (two Autotext entries or macros with the same name, etc. stored in different active templates)? 
They defer to each other according to rules set by Microsoft (but not very easy to discover). 
You don't need to know this hierarchy unless you start using the same names for macros, styles , building blocks or autotext entries in multiple templates loaded simultaneously. (This is a good reason for using different names!) The order is:
	
	First, look in the document.  
	
	Any macros or styles in the document will be used in preference to others if they have the same name.

	
	Any toolbar (QAT) or keyboard modifications stored in the document will trump those elsewhere. (If the document and a template both have toolbars with the same name, though, they will both be available when the document is active.)




	
	Next, check the attached template.  
	
	Any macros or styles in the attached template will take priority over any except those of the same name in the document. 

	
	Any styles created or changed in the template after the document was created will be available as changed to the document by updating styles. Without such an update, the document will not access the changes.

	
	Any autotext entries or other building blocks in the attached template will be used in place of those with the same name in Normal or global templates. (Documents don't hold autotext entries.)

	
	Any toolbar (QAT) or keyboard modifications stored in the attached template will trump those stored in Normal.dot[m] or other global templates.




	
	Then check the Normal template (Normal.dotm or Normal.dot).  
	
	All styles in Normal.dotm / Normal.dot when it was created are available to all documents. Those styles already in the document will not take on the attributes of styles in Normal.dot[m] unless you update them. (Normal.dot[m] has many more styles than are ever used in one document.)

	
	Any styles created or changed in the normal template after the document was created will be available as changed to the document by updating styles. Without such an update, the document will not access the changes.

	
	All macros and autotext (or other building blocks) in Normal.dotm / Normal.dot are available to all documents (unless preempted by an item of the same name in the attached template or the document). Normal.dot[m] is not the place to store shared macros.

	
	Any toolbar (QAT) or keyboard modifications stored in Normal.dotm / Normal.dot are applied. In case of conflicts between Normal.dot and other globals, Normal.dot[m] wins.




	
	Then, check other global templates and add-ins. Again, these do not contribute styles to documents but all macros, toolbars and Autotext entries are available from a global template.  
	
	Styles in global templates are irrelevant to documents (unless the style is incorporated in an autotext entry).

	
	If there is a macro or autotext entry with the same name in Normal.dot(m), the attached template, or the document, as the name in any other [previously checked] global template, the macro or autotext entry in the global template will not be used (except for an AutoExec macro).

	
	Any toolbar (QAT) or keyboard modifications are applied unless they conflict with something higher in the hierarchy. 

	
	If there are multiple global templates, they are checked in the order they appear in the Templates and Add-Ins dialog box (with the first found taking priority over those appearing lower on the list).




	
	Finally, check Word, itself. (The Word application stores its styles, autotext entries, formatted autocorrect entries and toolbar settings in Normal.dot(m) but will recreate Normal.dot[m] with default settings if it can't find the Normal.dot(m) file when started.) 
	
	While the Word application does not contain Macros, as such, it does contain Word commands (which show up as a category in the Word macro list). 

	
	These can be intercepted by macros which have the same name as the command. (See Intercepting Events Like Save and Print for more on this.)




	
	There are more rules that apply to Building Blocks and AutoText. They have two more templates, at least, involved. See same name.

	
	See also the hierarchy of which template is the attached template when there are multiple templates with the same name.
For more on this, you may want to look at How Word Manages Conflicts or Customizing Word: A Roadmap for the Professional Developer by Bill Coan, MVP. I do not know if there is any conflict in assignment of QAT modifications in the different template levels; I believe they are simply cumulative. 
In addition, which is the attached template can have its own hierarchy. It is not necessarily the template used to create the document!
See this Word Answers discussion for more about which template will be the "attached template" when the document is re-opened.


 
[bookmark: tabs]How to get more (user defined) tabs when you select “New” under the File menu.

When you go to save a template, as a template, Word 97-2003 will take you to your user templates folder. If you store the template there, it is under the General tab for new files. The other tabs that you see under File => New are usually folders in the user templates folder or the workgroup templates folder. If you want to add a tab, add a folder and store a template there. (In Word 2000 the tab won’t show up if there isn’t a template in the folder.)
Word 97 stores the templates that come with it in these same folders. Word 2000 keeps its built-in templates elsewhere. If you want your template to show up under the tab for “Letters & Faxes” you need to create a folder with that title in your user Templates folder. Just File=>Save As and select template as your file type. Before you save the template, create a new folder “Letters & Faxes” if one isn’t there, and then open that folder and store your template there.
[bookmark: NewTemplatesDialog]Word 2007 & 2010 New Templates Dialog
When you Choose File > New in Word 2007 or 2010 you get something like the dialog windows below:


To get to the classic dialog you click on "My templates." 
Want to get to your templates quickly? You can get the classic dialog by customizing the QAT (Quick Action Toolbar). You want to add the command for New Document or Template (classic FileNewDialog). See File New Variations in the Versions of Word for more on this.
Word 2013-2021 New Templates Dialog
Word 2013 changes things up yet again, still emphasizing the Online templates. 

What are shown are icons from Office Online's featured templates. To get to your own templates, you need to click on "Custom:"

For more on how Word 2013-16 has this set up, see File New Dialogs in Word. There is no way just clicking on buttons and menus in Word 2013-16 that you can view the combined File New dialog from earlier versions because unless set to be the same folder by the user, the user templates folder (shown in the classic FileNew dialog) and the Custom Office Templates folder are different folders..
You can use the Classic FileNew Dialog though by making some minor tweaks to your QAT or keyboard shortcuts. You can even add a button to your Ribbon. You can also download a free Add-In with these tweaks.
 
Tabs from a Workgroup Templates Folder
You can create organization folders in your workgroup templates folder as well and store your workgroup templates there. These tabs will then show up in the File => New dialog box for everyone who has set that folder as the location for workgroup templates.
If you give your folders (that you create in the user or workgroup templates folders) the same name as Tabs already showing up under File => New, your templates will show up under those Tabs. You can have folders with the same names in your personal templates folder and your workgroup templates folder to take advantage of this.
[bookmark: folder_organization]Template folder organization and the File => New dialog box.

Note that the folder depth allowed for Templates folders is two levels: the Templates folder and one level of folders therein. The diagram above shows five levels. You can put subfolders in second-level folders but Word will ignore that structure and act as if you put all the templates directly in the folder at the second level.
Word 97/98?
If your templates folder is structured as in the diagram when you use File => New you will see four custom tabs and five custom templates in your dialog box. If you click on the tab AA you will see no templates.
Word 2000/2001?/XP?
If your templates folder is structured as in the diagram, when you use File => New you will see three custom tabs and five custom templates. No tab is shown for AA because it contains no templates.
Both
If you click on the tab AB, you will see templates 11, 12, and 13 as options for starting your new document. If you click on the tab AD you will not see any folders. You will see the following templates: 17, 18, 21, 31, 32, 33, 34, 35, 36. All templates that are anywhere within folder AD, including in subfolders, are displayed.
Tabs that show up under File => New that are not Folders
	
	The General tab (Word 97 and thereafter)


The General tab displays all templates in the User templates folder, the workgroup templates folder and one that says "Blank Document." You won't find a "Blank Document.dot" if you look in any of the templates folders, this is actually Normal.dot(m).
	
	[bookmark: More]The More tab (Word 97 and thereafter)


If you have more folders in your user templates folder and in your workgroup templates folder than can fit on two rows of tabs in the File => New dialog box, the last tab on the second row will be "More." Clicking on this will give you all of the Folders in your templates folders.

	
	Other tabs that are not Folders (Word 2000 and thereafter)


In Word 2000 (and thereafter I expect) the templates that come with Word show up under tabs in your Files => New dialog but if you look for them, you can't find them. That is by design. Unless you have created a folder that has the same name as one of these tabs, there will be no folder with that name. If you do create such a folder (in either your user templates folder or your workgroup templates folder) you will have a folder that matches the tab. Any templates that you put into that folder will show up under the tab in the File => New dialog. (The templates under that tab that come with Word, though will still not be in the folder.)
[bookmark: removingtabs]Removing Tabs from the File => New dialog
First, read the section above on Adding Tabs so that you have an understanding of how templates and the templates' folders are organized and work.
Word 97/98
Move the folder (let's call it Folder A) outside of the Templates folder (or Workgroup Templates folder). If you want the templates in Folder A available under a different tab, you can move them to the folder for that tab or your can simply put the folder you no longer want to appear as a tab into a different folder that still will appear as a tab. If you put the folder (Folder A) into a different folder (Folder B) in the templates folder, the folder you moved (Folder A) will no longer appear as a tab in the File New dialog but its templates will all appear under the tab for Folder B.
Word 2000-2003
If your tab is created by a folder in your user templates folder or your workgroup templates folder, follow the instructions for Word 97/98. If it is a built-in folder, then you will have to uninstall those templates using Add/Remove Programs. For detailed instructions see this Knowledge Base Article Q210884 or run through the following steps (based upon a post by Gary Frieder on Woody's Word Lounge).
1. Close Word
2. Select Microsoft Office (your version) in Add/Remove Programs.
3. Click on the Change button.
4. Click on Add or Remove Features.
5. Click on the plus symbol next to Microsoft Word for Windows to expand it.
6. Click on the plus symbol next to Wizards and Templates to expand it.
7. You will see a number of categories such as Letters, Memos etc. These categories correspond to the tabs under File => New.
8. Click on the box symbol just to the left of any of these category names.
9. Click on the "X Not Available" option. This means just what it says, these templates will not be available unless you go back and reinstall them.
10. Then click on the "Update Now" button at the bottom right of the dialog.
If you just want to get rid of the tab but you still want (some of) the templates, you will need to reproduce those templates before you uninstall the category (tab). You can do this by creating and saving a new template (click the "New Template") checkbox in the File => New dialog box and save the template in a different folder / tab. Alternatively, the templates may actually exist on your hard drive, just not in your user templates folder. Look for a folder labeled 1033 (English language version) in C:\Program Files\Microsoft Office\Templates\. Again, this is not your user templates folder. Almost all installed built-in templates are in this folder. You can copy the one you want out of here into your user templates folder (or a folder therein).
There is a Registry hack for deleting tabs as well. This eliminates the tab but not the templates. (How you'll access them, though is anyone's guess.) It was published in Woody's Office for Mere Mortals. Not for the faint of heart. Back up your Registry before doing anything like this.
You may want to look at Graham Mayor's page on template locations for pictures of the steps in uninstalling templates in Word 2000-2003.
Word 2007-2010
This is a registry tweak. If you don't already know how to do edit the registry with regedit don't attempt this. Backup your registry before making any modifications.
With all Office components closed, use regedit to expand to 
HKEY_CLASSES_ROOT\Installer\Components\8F622368F04 F7B849A7B2021EE668F21 
Select individual keys and rename them to remove individual templates, or rename the top level key (8F622... etc) to remove them all, including the tabs. Add the word "NOT" to the start of the key to make this easily reversible. (This will put it at the end of the alphabetical order.)
Restart your computer.
As far as I can tell, this does not work with Word 2013 or later.
 
[bookmark: Opening]Opening a template for editing
You will need to know the location of the template before you attempt to edit it. 
In Windows, use Start => Find... => Files and Folders to do this. On a Mac, use the finder. 
For the Normal template, see How to Open and Find the Normal Template.
From Word
You open a template for editing the same way you open a regular document. (File => Open) The trick is navigating to the folder that contains the template. Once you have done this, simply open the template. Note that if you have opened the template the name shown in the title bar will be the template's name, not "Document 1." Since the task of navigating to the template is difficult, you may want to simply open the template ...
From Windows Explorer
You open a template for editing from Explorer by right-clicking on it and selecting "Open" from the shortcut-menu that pops up. If you simply double-click on the template, you will get a new document based on the template.
Note: Windows 11 - go to the bottom of the right-click menu and choose More Options... and then pick Open.
[bookmark: new_template]Using one template to create a new template
Once you have a good template, why re-invent it? You have your letterhead set up the way you want (see Letterhead System), why not use that template as a base for your form letter. Probably the best way to do this is to open the template as if to edit it and then save it under a different name before you change anything. Doing this (Save As...) will transfer macros and all styles into new template.
If you change the definition of a style in your new template, that style should continue to be applied to paragraphs that serve the same purpose in the new template as paragraphs using the style of the same name serve in other documents. If the style will serve a different purpose in the new template, it should have a different name, and perhaps be based on an existing style from the old template. Doing things this way makes it much easier to copy text between documents based on different templates. That leads us into a discussion of ...
Styles in Templates
The reasons for using styles in a template are the same as those for using them in your documents - in Spades: 
	
	Consistency — When you use styles to format your templates, documents having the same function will have a similar, familiar appearance and be easier for the reader to understand. Each section is formatted the same and therefore, provides a professional, clean-looking document. 

	
	Easier to Modify — If you use styles in your template consistently, you only need to update a given style once if you want to change the characteristics of all text formatted in that style. 

	
	Efficiency — You can create a style once, and then apply it to any section in the documents based upon the template without having to format each document individually. You can change a style in a template and update the styles in the attached documents easily. 

	
	Table of Contents — Styles can be used to generate a table of contents quickly. 

	
	Faster Navigation — Using styles lets you quickly move to different sections in a document using the Document Map feature and the vertical scrollbar's tips. 

	
	Working in Outline View — Styles allow you to outline and organize your document's main topics with ease. 

	
	Legal Outline Numbering – Numbering, when linked to styles, allows you to generate and update consistent outline numbering in legal documents, even ones with complicated numbering schemes like municipal law, tax law, and mergers and acquisitions documents. Failure to use numbering linked to styles is one of the easiest ways to really mess up a Word document. This applies to templates even more! 

	
	Efficiency of Word — Files which are predominantly manually formatted are less efficient than those which have formatting that has been imposed by styles: manually formatted files, such a converted documents which have been File, Opened, are bloated in file size (bytes) and do not render to the screen efficiently when you scroll through them. This is because Word is a styles-based application: it first reads the attributes of the underlying style, then has to broadcast anything contrary (e.g. manually formatted on top of that). As such, a lengthy document that has been predominantly manually formatted, will behave sluggishly because Word has to work harder at managing it. Additionally, the print formatting processes are equally labored as opposed to using styles. (Each paragraph mark in Word will carry up to thirty different formatting commands for the screen and printer. These can all be replaced by one style setting.) 

	
	HTML AND XML — What lies ahead? A fully structured, styled template will move into HTML and XML incredibly well.

	
	Bottom line — Use of any direct formatting in a document template is a very bad idea. 
It will cause users of your templates (and, if there is any justice in the world, you) uncounted headaches. For more on Styles, see that tutorial.


 
	
	Note  In Word 2000, styles are listed in alphabetical order. In Word 97 styles listed in the drop-down list are not displayed in alphabetical order. Word 97 lists styles in the following order in the Style Box list: 
	
	Heading styles 

	
	Normal style 

	
	User-defined styles in alphabetical order 

	
	Body Text styles 

	
	List styles 

	
	All other styles listed alphabetically.







	
	Warning  I do not recommend selecting the Automatically update the style box especially in a legal environment where multiple users work on the same document. This feature will update the style each time you make a formatting change in a paragraph that has a style attached.


  
In How to Create a Template - 2, John McGhie lays down the law using styles in templates, so well that it bears repeating:
"Always change formatting with Format>Style XE "Format>Style" .  I may sometimes forget to say so, in which case please remember it for me!  ...[R]emember: for most users, the only thing they can ever access in a template is the styles.  If the settings are not in the styles, they’re pointless." 
Using the Organizer to Copy Macros, Styles (and in pre-Ribbon Versions, AutoText and Toolbars)
You can copy styles and macros, AutoText, and toolbars between documents or templates. 
One of the most effective ways to do this is through the Organizer. In Word 97-2003 you can copy Toolbars and AutoText as well using the Organizer. Not so in the Ribbon versions.
The Organizer is a tool built into Word that allows you to quickly copy features from one document/template to another. 
Ribbon Versions: You can access the Organizer from the Manage Styles dialog or from the Document Template dialog.
Manage Styles is found at the bottom of the Styles Pane. The Document Template dialog can be reached through the button on the Developer Tab.
Menu Versions: You can access the Organizer in one of two ways: from the Format menu, choose Style and click Organizer; or from the Tools menu, choose Templates and Add-Ins and click Organizer.
This can get difficult, though, especially with toolbars. 
See Moving (Sharing) Customizations in Microsoft Word for my suggestions on how to do this. 
 
	
	Note  If a style name that you are copying already exists, you are asked if you want to replace it. 
I have found it best when copying styles using the organizer to copy them three times if any of the styles is based on other styles or is followed by other styles. I'm not sure why this makes a difference, but I've found that clicking on that copy button three times means that these relationships continue in the destination template. I know that when I copy them only once, they do not and the styles are then followed by the Normal style.


[bookmark: Keyboard]Copying Keyboard Shortcuts and menu modifications from one template to another
This is not as simple, because Word has no method built-in for doing it.
I do it by using a global template developed by Chris Woodman. His website has been down for a number of years, but you can download this for free from:
Chris Woodman's Add-In Links on my Downloads Page
Once you have placed the global template to have it work as a global, you have will have an additional command under Tools that says Organize keyboard. It works like the organizer. (This global also adds a command under the Edit menu that lets you use document variables like document properties.) 
I recommend that you open this template and read it. Then, while in the template, right click on your toolbars and un-check "Shortcuts." I find the toolbar to be overkill. You may also want to remove the document variables command that is now under your File menu. To do this...
Tools => Customize
Drag the command off of the menu and into your document. 
I've added an Add-In with Chris Woodman's Code for use in Ribbon Versions of Word. Look for it on the same page. Chris Woodman's Add-In Links on my Downloads Page
[bookmark: content_stays_in_a_document]What content stays in a document created from a template when the template is no longer attached to the document?
The following do not stay in the document but rather depend on the attachment to the template:
1. Macros (and userforms) in the template. If you want the macros in your document, the document must be a docm or doc format document and you must move them there. That project is beyond the scope of this article. (A userform is a vba construct, a custom dialog box.)
2. Keyboard Shortcuts in the template. If you want to copy them using Chris Woodman's Keyboard Organizer, you can do so.
3. AutoText and Building Blocks reside only in templates and do not transfer as such to documents based on a template. However, when actually inserted into a document based on a template, they remain in the document as text.
The following do stay in the document even when it is divorced from the template:
1. Page layout.
2. Document variables which may or may not be displayed anywhere in the document.
3. Document Properties which may or may not be displayed anywhere in the document.
4. Headers and footers even if not displayed. (This can be a source for metadata or confusion if the templates are not properly constructed).
5. Any text hidden or otherwise.
6. Styles from the template, but see below.
7. AutoText and Building Blocks that were inserted directly into a document while it is attached to a template become text in the document. They remain even after the template is not attached.
However, if they are inserted using AutoText fields, rather than as text, they will be lost when the AutoText/Building Blocks are no longer available.
8. Editing Restrictions
A document will always be divorced from its template when it is sent to someone else by email. It may attach to a template of the same name on the recipient's computer, this is a matter of happenstance.
If you have the option set in a document to update styles automatically from the template, the styles in your document may change to match an unknown set of styles on the recipient's computer.
See What happens when I send my document to someone else? Will Word mess up my formatting? and What is the relationship between a Microsoft Word document and its template?
[bookmark: Macros]Macros in Templates and Documents
Macros get into templates or documents by being recorded or by using the VBA editor (or being put there by another macro). Because of the warning that pops up when Word detects macros, many Word users are very leery of them. This is unfortunate because they are one of the best tools available for getting Word to work the way you want it to work. 
It is all a matter of trust though. A bowl of soup can be very tasty and provide needed nourishment. It can also contain poison or a disease. For this reason, I recommend that the macro virus security be set at least at medium in all versions of Word that have such security (Word 97 and later.)
This area is a draft and very much a work in progress. For most users this is something they never need to know or worry about. It is likely to end up in a separate chapter. This is pretty much everything I know or think I know about Auto macros and hasn't all been tested. It is also covered in many other books and isn't specific to law office use. 
[bookmark: AutoMacros]Auto Macros
There are a class of macros that can be put into a template or document that run without any notice to the user and without being called by a toolbar or button. These are known as "auto" macros and include: 
	
	AutoOpen - document/template opened
- Document_Open in ThisDocument

	
	AutoClose - document/template closed
- Document_Close in This Document

	
	AutoExec - Word started up or Template added as global

	
	AutoExit - Word closed (exited) or Template unloaded as global

	
	AutoNew - new document created
- Document_New in ThisDocument



	
	Tip  You can keep these macros from running by holding down your Shift key while opening (closing) the document / starting (exiting) Word.


You can keep the macros from running by holding down your Shift key while opening (closing) the document / starting (exiting) Word. 
The AutoOpen Macro runs when an existing document or template is opened (not when a new document is created). 
If you put an AutoOpen macro in Normal.dot(m), it will run every time any document (or template) is opened. (It will also run anytime you open Normal.dot(m).) 
If you put an AutoOpen macro in a template, it will run anytime a document based on the template is opened (so long as the template remains attached). It will also run anytime the template is opened. It will run instead of any AutoOpen macro in Normal.dot(m). 
If you put an AutoOpen macro in a global template, it will run only when the template is opened. You can run a global macro upon the opening of any document by placing the following macro in that document's template: 
Sub AutoOpen()
     Application.Run.MacroName:="myGlobalMacro"
End Sub
You can also run a macro in a global template upon opening any document by using the document open event. 
AutoClose macros work the same as AutoOpen macros except that they run when a document or template is closed. 
[bookmark: AutoExec]AutoExec macros are for use only in Normal.dot(m) and other global templates. The will run anytime the template containing the macro is loaded. (For Normal.dot(m) and automatically loading globals this is when Word is started. For other global templates it is when the template is loaded as an Add-In. AutoExec macros can be in Normal.dot(m), global.dot, global2.dot, etc and all of them will run! Normally when you have macros with the same name in multiple active places, only the macro closest to the document runs. For AutoOpen macros, if you had an AutoOpen macro in Normal.dot(m), the attached template, and the document only the macro in the document would run.) The following is an example of an AutoExec macro that disables the web toolbar. 
Sub AutoExec()
     Application.CommandBars("Web").Enabled = False
End Sub
  
AutoExit macros work like AutoExec macros except that they run when the template is unloaded. For Normal.dot(m), that means when Word is closed. For globals it means when Word is closed or when the global is unloaded using Templates and Add-Ins.  
AutoNew macros have no use in documents or global templates, only in document templates and in Normal.dot(m). An AutoNew macro in Normal.dot(m) will run anytime a new document is created. An AutoNew macro in a document template will run whenever a document is created based on the template. If there are AutoNew macros in both Normal.dot(m) and in the document template, the macro in the template will run and that in Normal.dot(m) will not. 
The following sample macro can be used to test when a macro is called: 
Sub AutoOpen()
' Test macro
     MsgBox "The AutoOpen macro in Normal.dot is running"
End Sub
Note that you have to write this macro in the VBA Editor, you can't just record it. If you want to record a macro to test, you could record a macro that types some text, pauses, and then deletes that text. 
Here is a macro to backup your Normal.dotm template. Backup Normal Template Macro 
See: Creating a macro with no programming experience using the recorder by Bill Coan, MVP 
See also: How to assign a Word command or macro to a toolbar or menu by Dave Rado 
See also: Running a macro automatically when a document is created, opened or closed by Dave Rado 
See also: The art of defensive programming by Jonathon West, MVP 
See also: Customizing Word: A Roadmap for the Professional Developer by Bill Coan, MVP
Much more to write here. This will probably end up in a separate chapter on macros. I should also include the vba code to locate the User Templates folder and the Workgroup Templates folder. 
	Troubleshooting Templates — Issues To Watch Out For
	
	Failure to define and use styles. This is especially a problem if you have numbered paragraphs that use Word's automatic numbering.

	
	Template conflicts. Using the same names for macros, styles, and/or autotext entries in multiple active templates. There are times when you want to do this but usually you don't want one template pre-empting another.

	
	Multiple copies of the Normal template (Normal.dot/Normal.dotm). Unless you have multiple users on a computer and have user profiles activated, there should only be one Normal template on your computer. (You should also have multiple Normal templates if you have multiple versions of Word on your computer.) If you have user profiles activated, there should only be one version of the Normal template per user (per version of Word).


 


[bookmark: EditingNotes]This is definitely a work in progress. I have posted it and placed it in the table of contents because I think that it is finished enough to be more help than harm. I work on it (and the other chapters listed below) in my spare time as the mood strikes me. Please let me know of any errors you spot or any suggestions you have to make it more useful. Thank you.
You can reach me by e-mail.
Other very rough chapters in development but not listed in the table of contents are:
	
	Automated Boilerplate Using Microsoft Word (now in Table of Contents) - AutoText, AutoCorrect, Building Blocks

	
	Using Fields in Microsoft Word

	
	Making Forms with Microsoft Word
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Templates are a special type of Word file that
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rge part of your job in creating a new document will 
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You don't have to understand everything in those chapters to build a useful template, but it will help for you to at least ha
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skimmed through so that you will know some of the pitfalls and a
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Distinguish between a "template" and an ordinary document
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